SilverR07

Lancer Ecu Help

5 posts in this topic

So I was going to tune my Lancer's ECU using EcuFlash. And when I clicked to read the ROM, it started loading the kernel and then closed the interface again and showed an error box. After that happened my car fan is running and my dash says "Engine overheating" along with other service alerts. The car cranks but doesnt turn over. Ive tried disconnecting the ecu from the car for a couple hours but it doesnt seem to help. Has anyone ever encountered this and know what to do?

0

Share this post


Link to post
Share on other sites

I've never flashed the ECU, but it sounds like you totally crashed the program and need to buy a brand new ECU from Mitsubishi...

0

Share this post


Link to post
Share on other sites

Goto works evo get their tune and a tarix port and fix what you faulted up all ecu in base are locked and evo past 2010 works is the only one I know who can safely flash stock lancers and I heard rrm can too

Sent from my iPhone using Tapatalk

0

Share this post


Link to post
Share on other sites

2010+ have extra protection for overwriting the rom, but reading should have been fine. Sounds more like you had software crash in the wrong moment and ecu is stuck in access mode. Mitsubishi dealer will most probably be able to reset it very easily but you will have to do some explaining about what were you trying to do and eventually loose your warranty.

0

Share this post


Link to post
Share on other sites

my lancer has reflash without any problem

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now