d.garciaGTS

Getting a weird idle when coming to a stop.

7 posts in this topic

Any body have this problem when the car is completely warm and come to a stop with the clutch disengaged or in neutral?

 

0

Share this post


Link to post
Share on other sites

Yea i looked at my throttle body and it didnt look too dirty at all, like ive seen way worse than what it was, cleaned out my IAC pretty good. Could always do the throttle body again another day. Checked my MAF and it seemed fine. Honestly im beginning to think its a small vac leak, my plugs and coils, or my new alternator screwing up. 

0

Share this post


Link to post
Share on other sites

Did you spray cleaner on the MAF sensor? The wires are so tiny you may not see it but could still need a clean. Use MAF sensor cleaner only if you do. Also if you have a cone air filter check to see if it needs to be cleaned up too. When I bought my car the cone filter left my hands black and greasy, so I just threw it away and swapped with a new K&N. They do need a periodic clean.

0

Share this post


Link to post
Share on other sites

In European models, 4B12 engines are equipped with EGR valves. After some time they get clogged and cause the same symptoms as dirty throttle body. Plenty of similar videos out there: https://www.youtube.com/watch?v=_Q20H6f7TmY  

Usually when TB needs cleaning, EGR valve gets cleaned at the same time. However I am still not sure if North American 2.4l Lancer engines are equipped with one. Probably You have same plug on it as middle eastern versions, but still worth to check. 

BTW, when I had to clean TB due to same rough idle and stalling on the stops, it although looked quite clean, but still caused problems. 

 

1

Share this post


Link to post
Share on other sites

While you're checking electrical take a look at the connectors leading to all of the sensors mentioned above, looking for frayed wires, corrosion, and misaligned pins, as that could also do you in

0

Share this post


Link to post
Share on other sites

Thanks a lot guys, I’m having a my mechanic look into it and have him check my whole intake system out on wednesday. If we found out the problem I’ll be sure to let you guys know what it was. 

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now