hollywood91

Members
  • Content count

    212
  • Joined

  • Last visited

Community Reputation

3 Neutral

3 Followers

About hollywood91

  • Rank
    Member
  • Birthday 10/06/1991

Profile Information

  • Gender Male
  • Location Nanaimo
  • Car Lancer DE

Recent Profile Visitors

284 profile views
  1. Hollywood's Progress Thread

    So I have moved away from owning a Lancer. I traded it in for a 2014 Escape. Loving the extra room and the turbo charged eco boost engine. I even love the style of the vehicle. Happiest change I've made. I'll still be lurking once in a while but my Lancer days are done. This site has been great for helping me out and for sharing my finds. Good luck to all the Lancer owners out there. Sent from my SM-G920W8 using Tapatalk
  2. Front End Done!

    Looks good. Just installed my lip on my white lancer. Went gloss black for everything to switch it up
  3. Gloss Black Out

    I was toying with the idea of going gloss black on the nose and center lip on my WW Lancer. I have gloss black rims. I have gloss black vinyl coming for the roof. Has anyone done this or what are your thoughts on this.
  4. Did you ever get this solved? I have a similar problem in my 2013 CVT. It only makes the sound when going really slow or sitting stopped in park. If I shift from drive to any other position the sound goes away.
  5. Just wondering if Eibach springs for a 2010 Ralliart will fit on a 2013 SE. I did a little research with no good results.
  6. Make Your Rear Bumper Look Better For $20!

    Looks awesome. It's convinced me to do this on my next day off work Sent from my iPad using Tapatalk
  7. Transmission Issue?

    Yea I have the cvt. It just surprised me a little to hear it. This is a brand new transmission. I heard it when going through a Timmies drive thru. Kind of embarrassing when you are sitting at the window and the car is making a whining noise. I'll have to see if I can't get the dealership to look at it again Sent from my iPhone using Tapatalk
  8. Transmission Issue?

    So I had the transmission replaced in my 2013 SE a couple months ago under warranty. Now after driving it for a little bit it will make a kind of whining noise when idling in drive and only in drive. The other issue I have noticed is if I lose traction or hydroplane the engine will run at really high rpms when trying to accelerate. This goes away after coming to a complete stop. I don't have to turn off the car or take it out of park but this is annoying when driving down e highway and hitting a puddle. The car will barely accelerate when this happens. I went to the dealer but they said they couldn't replicate the noise so the is nothing they can do. Just wondering if anyone has experienced anything like this. Sent from my iPad using Tapatalk
  9. ALL About Intake Systems

    I haven't run mine on a dyno but I have driven my car multiple times with and without the intake. I notice the car to respond faster when accelerating especially from a stop. Could be placebo for me but I have done many personal tests. I also find it gives a bit if a push when accelerating when already doing say 80 km/h
  10. Hollywood's Progress Thread

    Yea definitely handles better in the corners
  11. Hollywood's Progress Thread

    So been a long time but finally did some work on the car. Rrm front strut bar, handling is even better now, eyelids which are not painted yet, painted the roof black until I can wrap it, added some white cloth to the interior. Will post up pics when I get the chance later
  12. Lancer Did You Knows !

    If this happens too many times in a row because your friend is being stupid the window will actually stop moving entirely until the car is restarted or the window is not touched for a few minutes.
  13. Debadging

    I also used painters tape around the area as to make sure I didn't somehow accidentally scratch the car. I didn't even need goo gone. Just pulled the remaining adhesive off and wiped it down with water and a micro fibre cloth. You can't even tell they were there
  14. Debadging

    Going to remove the mistu and lancer right now. Sent from my iPad using Tapatalk
  15. Debadging

    I have a 2013 WW SE. I have been battling in my mind as whether or not to debadge the trunk. I don't have a spoiler and I'm not sure if that helps with the appearance on e back end with the emblems being removed. Does it look better to remove all three pieces from the back or to leave the centre emblem and just remove Mitsubishi and Lancer? Sent from my iPad using Tapatalk